u16suzuの blog

u16suzu のブログです。

Ruby on Rails をインストールする。

Ruby on Railsをインストールする時、ちょっとハマったのでメモ。

コマンドを叩いたらバージョンが不正で失敗。
どうやらRailsのインストールにはRubyGems の version 1.3.5 が必要な模様

C:\Documents and Settings\u16>gem install rails
ERROR:  Error installing rails:
        i18n requires RubyGems version >= 1.3.5

C:\Documents and Settings\u16>gem -v
1.3.4

コマンドがわからずに、RubyGemsの公式を参考にしました。
Adminかrootである必要があります。
http://rubygems.org/pages/download

$ gem update --system    

RubyGems 1.6.2にアップデート完了

C:\Documents and Settings\u16>gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.6.2
Updating RubyGems to 1.6.2
Installing RubyGems 1.6.2
RubyGems 1.6.2 installed

RubyGems installed the following executables:
        C:/Program Files/ruby-1.8/bin/gem

C:\Documents and Settings\u16>gem -v
1.6.2

Railsのインストール完了

C:\Documents and Settings\u16>gem install rails
Fetching: activemodel-3.0.5.gem (100%)
Fetching: rack-1.2.1.gem (100%)
(省略)
Fetching: bundler-1.0.10.gem (100%)
Fetching: rails-3.0.5.gem (100%)
Successfully installed i18n-0.5.0
Successfully installed activemodel-3.0.5
(省略)
Successfully installed bundler-1.0.10
Successfully installed rails-3.0.5
22 gems installed
C:\Documents and Settings\u16>